Cgminer Not Showing Gpu But Giving Hashrate

Discussion in 'cgminer' started by Nabob, Feb 19, 2016.

  1. 2017/12/15 - Decred v1.1.2 released! → Release Notes  → Downloads
  1. Nabob

    Nabob New Member

    Feb 18, 2016
    19
    3
    Male
    hello everyone, my cgminer shows a hashrate and accepted shares, but it doesnt show any gpu settings or options. I am running windows 7 32 bit, and the appropriate cgminer software with support for DCR, and my card is an MSI r9 280x gaming 3g twin frozr edition. my driver is the 13.11 amd driver. here is a screenshot of the problem. Capture.PNG

    you can see where it says "GPU 0:" those fields are blank, but they shouldnt be. I also cannot access the gpu settings under [G]PU management. Do i need to do something further to get cgminer to configure my card better?

    thanks for any help you can provide!
     
  2. MiloIce

    MiloIce Jr. Member

    Jan 18, 2016
    206
    26
    Male
    Are you running it on remote desktop?
     
  3. Nabob

    Nabob New Member

    Feb 18, 2016
    19
    3
    Male
    no, regular desktop mode.
     
  4. LastNinja

    LastNinja Full Member

    Dec 31, 2015
    451
    199
    Male
    When you click in the systray on the arrow up and then on the Radeon settings icon, will the software open or will it not and just issue an error like "no suitable driver..."?

    If it won't open then you have probably an iGPU which is activated. Disable it in BIOS and everything will work fine.
     
  5. Nabob

    Nabob New Member

    Feb 18, 2016
    19
    3
    Male
    it opens up just fine, and my integrated GPU is disabled in the bios.
     
  6. MiloIce

    MiloIce Jr. Member

    Jan 18, 2016
    206
    26
    Male
    you might want to try this driver out? Here
     
  7. Nabob

    Nabob New Member

    Feb 18, 2016
    19
    3
    Male
    tried that driver you linked, still not working.:(
     
  8. Xsoldier

    Xsoldier New Member
    Advocate (Twitter)

    Dec 18, 2015
    12
    4
    Male
    I think you need to install the AMD Display Library SDK which gives you more access to video card. (Thread Concurrency, fan speed etc.) Did you build cgminer yourself?
     
  9. Halestorm

    Halestorm Jr. Member

    Jan 22, 2016
    83
    32
    Male
    Data Center
    Texas, USA
    If he's running Windows and the latest driver it should all be kosher. Can you paste the contents of cgminer.conf (minus any passwords of course) and the command line you're using to start it up?
     
  10. Nabob

    Nabob New Member

    Feb 18, 2016
    19
    3
    Male
    But i was running a previous version of cgminer that would let me access the fan speeds and all that stuff within the miner itself.

    yeah, im running windows 7 sp1 32 bit. I had no problems with cgminer and sgminer previously on this card. I don't have a conf file, but here is my .bat:

    cgminer.exe --blake256 -o http://dcr.pool.mn:4722 -u ** -p ** -I 12 --no-submit-stale --scan-time 2 --queue 0
    **-username and password hidden.
     
  11. Nabob

    Nabob New Member

    Feb 18, 2016
    19
    3
    Male
  12. jolan

    jolan Sr. Member
    Developer

    Dec 7, 2015
    197
    226
    Male
    Decred Team Member
    The build you're using probably doesn't have ADL support enabled. Unfortunately, the 32 and 64 bit builds of cgminer were built by different people using different methods.

    There will be an RFP for improving the mining software/binaries/stack so improvements should be coming soon.
     
  13. Nabob

    Nabob New Member

    Feb 18, 2016
    19
    3
    Male
    how long do you think it may take before we see those improvements?
     
  14. jolan

    jolan Sr. Member
    Developer

    Dec 7, 2015
    197
    226
    Male
    Decred Team Member

Share This Page