Cgminer Source

Discussion in 'cgminer' started by SG-O, Jan 26, 2016.

  1. 2017/12/15 - Decred v1.1.2 released! → Release Notes  → Downloads
  1. Wolf

    Wolf Jr. Member

    Jan 25, 2016
    107
    45
  2. Wolf

    Wolf Jr. Member

    Jan 25, 2016
    107
    45
    #42 Wolf, Feb 4, 2016
    Last edited: Feb 4, 2016
    Everyone using my builds should update to the latest one here for Win64:

    https://ottrbutt.com/miner/downloads/decred-cgminer/wolf-decred-cgminer-02042016-win64.zip
    https://ottrbutt.com/miner/downloads/decred-cgminer/wolf-decred-cgminer-02042016-win64.zip.sig

    These are based off of the official Decred CGMiner GitHub sources found at https://github.com/decred/cgminer - branch 3.7, commit c172a7a62455fae62afdc7995021f5c046aab9d7 with small modifications to get it to build with my set of Win64 tools. As before, it should require no DLLs other than what ships with Windows to function. Failure to upgrade may result in rejected/duplicate shares when pool mining, and/or other bugs.
     
  3. chappjc

    chappjc Full Member
    Developer Pool Operator (PoS)

    #43 chappjc, Feb 6, 2016
    Last edited: Feb 6, 2016
    Source has changed since Tuesday, so perhaps it's working for you now.

    From launch of the dered fork, cross-compilation for a Windows host from a Linux build machine was broken. That part got fixed quickly, but it briefly broke ADL detection for native Linux builds. That should have been fixed a few days ago in this commit, which lets ADL detection work on the following build/target setups I have tested: Arch Linux (native), Arch / MinGW-w64 (cross compile), Windows / MinGW-w64.

    If when you clone to a fresh folder, re-copy the ADL headers, plus the usual setup and configure, and if configure still fails to find ADL, please post your config.log. It seems to work for me and other developers at the moment, but someone else reported a problem. See here.

    EDIT: sammy007 uncovered the problem, which seems to be related to older compilers, namely GCC 4.8. There will probably be a fix shortly, which will hopefully support all build configurations.
     
    tacotime likes this.
  4. chappjc

    chappjc Full Member
    Developer Pool Operator (PoS)

    tacotime likes this.
  5. CommanderVenus

    CommanderVenus New Member

    Jan 11, 2016
    27
    4
    Linux 64 bit.
    Thank you for the replies chappjc! I had Wolf walk me through cloning instead of building from source and it wound up working for me though. Steps are below for anyone to use.

    1. Run: git clone https://github.com/decred/cgminer decred-cgminer
    2. Edit autogen.sh. Starting with the 'if test' line, delete that and everything under it. Save and close.
    3. Run: ./autogen.sh
    4. Add the three adl files from the include folder found in ADL_SDK9 into the cgminer ADL_SDK folder.
    5. Run: ./configure --enable-opencl --enable-adl --enable-blake256
    6. Run: make
     
    chappjc and tacotime like this.
  6. chappjc

    chappjc Full Member
    Developer Pool Operator (PoS)

    #46 chappjc, Feb 6, 2016
    Last edited: Feb 6, 2016
    I'm glad you were able to clone, configure and build. However, step 2 in your post will be unnecessary if it's not already.

    The issue seems to involve certain systems, not sure what about them, but please see the one line edit to configure.ac that fixed it for one person. I haven't submitted a PR yet, but I guess I will.
     
  7. Where is cgminer for Win 32 bit ??
     
  8. jumparo

    jumparo New Member

    Mar 27, 2016
    23
    0
    Hey guys, I'm having error running ./autogen.sh :

    $ ./autogen.sh
    configure.ac:39: error: possibly undefined macro: AC_PROG_LIBTOOL
    If this token and others are legitimate, please use m4_pattern_allow.
    See the Autoconf documentation.
    autoreconf: /usr/bin/autoconf-2.68 failed with exit status: 1

    Please advise what to do here,
    Thanks!
     
  9. chappjc

    chappjc Full Member
    Developer Pool Operator (PoS)

    Try installing libtool and/or libtool-dev, something like that.
     
  10. jumparo

    jumparo New Member

    Mar 27, 2016
    23
    0
    Hello guys, I have a problem during building cgminer from source .I am using msys2.
    Here is the error after running this commands :

    ./configure --enable-scrypt
    ./configure --enable-opencl

    Configuration Options Summary:

    libcurl(GBT+getwork).: Enabled: -lcurl -lidn -liconv -lssh2 -lssl -lz -lcrypto -lz -lssl -lcrypto -lssl -lz -lcrypto -lz -lgdi32 -lgssapi -lheimntlm -lkrb5 -lhx509 -lcom_err -lcrypto -lasn1 -lwind -lheimbase -lroken -lsqlite3 -lcrypt -lz
    curses.TUI...........: FOUND: -lncurses
    OpenCL...............: Detection overrided. GPU mining support DISABLED
    configure: error: No mining configured in

    and after :

    /autogen.sh --enable-opencl


    Configuration Options Summary:

    libcurl(GBT+getwork).: Enabled: -lcurl -lidn -liconv -lssh2 -lssl -lz -lcrypto -lz -lssl -lcrypto -lssl -lz -lcrypto -lz -lgdi32 -lgssapi -lheimntlm -lkrb5 -lhx509 -lcom_err -lcrypto -lasn1 -lwind -lheimbase -lroken -lsqlite3 -lcrypt -lz
    curses.TUI...........: FOUND: -lncurses
    OpenCL...............: NOT FOUND. GPU mining support DISABLED

    configure: error: No mining configured in


    I have installed AMD-APP-SDK-v2.8.1.0-Windows-64 and libOpenCL.a is in mingw/lib folder.

    Any ideas ?

    Thanks!
     
  11. chappjc

    chappjc Full Member
    Developer Pool Operator (PoS)

    #51 chappjc, Jun 21, 2016
    Last edited: Jun 21, 2016
  12. jumparo

    jumparo New Member

    Mar 27, 2016
    23
    0
    I ran first autogen.sh and i got the error i showed and then ./configure. Then i tried /autogen.sh --enable-opencl and ./configure --enable-scrypt. Now I tried the commands from the link you provided and that's the error i got :


    Configuration Options Summary:

    libcurl(GBT+getwork).: Enabled: -lcurl -lidn -liconv -lssh2 -lssl -lz -lcrypto -lz -lssl -lcrypto -lssl -lz -lcrypto -lz -lgdi32 -lgssapi -lheimntlm -lkrb5 -lhx509 -lcom_err -lcrypto -lasn1 -lwind -lheimbase -lroken -lsqlite3 -lcrypt -lz
    curses.TUI...........: FOUND: -lncurses
    OpenCL...............: NOT FOUND. GPU mining support DISABLED
    configure: error: No mining configured in
     
  13. chappjc

    chappjc Full Member
    Developer Pool Operator (PoS)

    Did your set the environment variable to point to the AMD APP SDK?
     
  14. jumparo

    jumparo New Member

    Mar 27, 2016
    23
    0
    Yes, i set the path
    export AMDAPPSDKROOT=C:\msys64\var\AMD APP\include

    Is that right or it should be different path ?
     
  15. chappjc

    chappjc Full Member
    Developer Pool Operator (PoS)

    Omit "include". Also, you'll probably have to translate the path to /c/msys64/var/AMD\ APP. Get rid of the space to avoid trouble.
     
  16. jumparo

    jumparo New Member

    Mar 27, 2016
    23
    0
    still the same :(
     
  17. chappjc

    chappjc Full Member
    Developer Pool Operator (PoS)

    Make sure the SDK is the right platform and architecture.
     
  18. root

    root Member

    Feb 3, 2016
    381
    76
    I haven't used Windows for some time, but I'd say you need
    export AMDAPPSDKROOT="C:\msys64\var\AMD APP"
    (with quotation marks) or rather do not use spaces at all (rename it) or possibly use Visual studio (OpenCL help).
     
  19. jumparo

    jumparo New Member

    Mar 27, 2016
    23
    0
    SDK is the right platform and architecture. The path is without spaces. :(
     
  20. jumparo

    jumparo New Member

    Mar 27, 2016
    23
    0
    I am having strange error and I have searched the whole Google, and there is nothing about it...please help.

    I try to compile cgminer from https://github.com/decred/cgminer , but have error when make :

    cgminer.c: In function ‘kill_mining’:
    cgminer.c:3399: error: invalid operands to binary !=
    cgminer.c:3403: error: invalid operands to binary &&
    cgminer.c: In function ‘api_thread’:
    cgminer.c:5250: error: incompatible types in assignment
    cgminer.c: In function ‘main’:
    cgminer.c:8677: warning: integer constant is too large for ‘long’ type
    make[2]: *** [cgminer-cgminer.o] Error 1
    make[2]: Leaving directory `/home/cgminer'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/cgminer'


    Any ideas? I 'd appreciate any help!

    Thanks in advance!
     

Share This Page