Dcrctl Only Returns Errors

Discussion in 'Technical Support' started by phzi, Apr 15, 2016.

  1. 2017/12/15 - Decred v1.1.2 released! → Release Notes  → Downloads
  1. phzi

    phzi New Member

    Apr 15, 2016
    13
    2
    Non-echelon
    I've read thru all the overviews and tutorials, entirely cleared dcr related appdata and started fresh, tried both v0.0.8 and v0.0.10, but I can't figure this out. Doesn't seem to be any results on the forum for these errors either. I've created the 3 conf files in APPDATA with the same passwords set in each (and tried without these as well, entering -u and -P lines for each cmd).

    dcrd is running in a cmd prompt; fully synced and getting new blocks as the network finds them.
    dcrwallet /create ran in another cmd prompt and followed steps to create a new wallet.
    dcrwallet ran and entered password to unlock the wallet.

    in a third cmd window, I try these commands get the following errors:
    >dcrctl.exe --wallet listaccount
    {
    "default": 0,
    "imported": 0
    }

    >dcrctl.exe --wallet getinfo
    -1: Chain RPC is inactive

    >dcrctl.exe --wallet getnewaddress
    -4: Address pools for account 0 are undeclared

    >dcrctl.exe --wallet walletinfo
    -1: Chain RPC is inactive

    Please tell me I'm missing something obvious?
     
  2. drunkenmugsy

    drunkenmugsy Sr. Member
    Advocate (Reddit)

    Dec 28, 2015
    405
    218
    Male
    Find some set up how to's in my sig. Read the links.
     
  3. tacotime

    tacotime Hero Member

    Dec 7, 2015
    410
    1,133
    Problem was resolved in the #decred IRC. Related to issue #179, which is fixed by pull request #180. The fix is not in v0.0.10, but will be in the next release. Thank you for your patience. Slowly but surely the software improves!

    In summary, dcrwallet is waiting for you to enter your passphrase. The prompt isn't very clear at the moment, so you may have missed it.
     

Share This Page