How I Finally Got My Airdrop Coins Into My Main Decred Wallet

Discussion in 'Technical Support' started by Reynold, Feb 10, 2016.

  1. 2017/12/15 - Decred v1.1.2 released! → Release Notes  → Downloads
  1. Reynold

    Reynold Member

    Jan 28, 2016
    First a little history of what happened to me...

    I thought my hash rate was to low to get any significant coins by mining, so before I even attempted to get the airdrop coins, I created a new wallet and bought some DCR from the exchanges.

    After I got all the coins I wanted to purchase, I was looking into getting my Airdrop coins. I could see them in the block explorer, but didn't know how to do it. Scanning the threads, I tried to use the web wallet, but it still says 0 balance. I noticed that even though I used my seed, it created a new first address.

    @ceejep showed me the command how to create another wallet on my windows machine.

    Here is how I finally got my Airdrop Coins into my Main Decred Wallet. Note, I'm doing this on Windows.

    • Get a new address from your main wallet (you will need it later)
    • Make a new folder for your wallet:
    • Create Your Airdrop Wallet:
    dcrwallet.exe --create --datadir "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop" --logdir "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop
    • Start your Airdrop Decred Wallet:
    dcrwallet.exe -u YourUserName -P YourPassword --datadir "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop" --logdir "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop
    • Unlock Airdrop Decred Wallet: (Note you will always have to use the rpc.cert in the new folder or dcrctl will not work)
    dcrctl -u YourUserName -P YourPassword --rpccert "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop\rpc.cert" --wallet walletpassphrase "Do not use this passphrase or you will be robbed" 0
    • Get balance of Airdrop Decred Wallet: (You will need this for the transfer)
    dcrctl -u YourUserName -P YourPassword --rpccert "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop\rpc.cert" --wallet getbalance
    • Find the paytxfee: (You will have to subtract this from your sendtoaddress amount)
    dcrctl -u YourUserName -P YourPassword --rpcert "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop\rpc.cert" --wallet getinfo
      "version": 100,
      "protocolversion": 1,
      "walletversion": 4,
      "balance": 282.63795424,
      "blocks": 884,
      "timeoffset": 0,
      "connections": 3,
      "proxy": "",
      "difficulty": 163557.62187443,
      "testnet": false,
      "keypoololdest": 1455162158,
      "keypoolsize": 0,
      "unlocked_until": 0,
      "paytxfee": 0.05,
      "relayfee": 0.05,
      "errors": ""
    • Send the DCR minus the "paytxfee" to your new address you created for your main wallet earlier:
    dcrctl -u YourUserName -P YourPassword --rpccert "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop\rpc.cert" --wallet sendtoaddress "DXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXy" 282.????????
    • Check your balance again on your Airdrop Decred Wallet, make sure it is 0.
    dcrctl -u YourUserName -P YourPassword --rpccert "C:\Users\YourUserName\AppData\Local\Dcrwallet\airdrop\rpc.cert" --wallet getbalance
    • Now you can shut down this wallet, and start up your main wallet
    • List the transactions
    • Check the balance and the Airdrop coins are there
    Anyways, this is what worked for me. I thought I would list it here in case anyone was having the same problem.
  2. LewiesMan

    LewiesMan New Member

    Jan 17, 2016
    I got screwed with the airdrop... The seed I got was supposedly a "genereric" test seed (which I was never told) + I never got any links to any so-called proper windows-software etc, yet I'm the bad guy?!:mad::mad: Bitch! please.... Why couldn't you just tell me the truth from the start?!
    Instead of getting my hopes up for nothing... AGAIN!!:mad::mad:

Share This Page