How To Build A Pool For Decred?

Discussion in 'PoW Pools' started by saymissme, Feb 7, 2016.

  1. 2017/12/15 - Decred v1.1.2 released! → Release Notes  → Downloads
  1. saymissme

    saymissme New Member

    Feb 2, 2016
    8
    0
    hi
    i was use pushpool to build a pool for Decred
    it is working
    like this:
    Code:
    [2016-02-07 15:54:5.452460] Debug output enabled
    [2016-02-07 15:54:5.453071] Forcing local hostname to dcrd.idcray.com
    [2016-02-07 15:54:5.459985] Listening on host :: port 8336
    [2016-02-07 15:54:5.460466] Listening on host :: port 10011
    [2016-02-07 15:54:5.464716] initialized
    JSON protocol request:
    {"method": "getwork", "params": [], "id":1}
    
    * Hostname was NOT found in DNS cache
    *   Trying 127.0.0.1...
    * TCP_NODELAY set
    * Connected to 127.0.0.1 (127.0.0.1) port 19109 (#0)
    * Server auth using Basic with user 'ray'
    > POST / HTTP/1.1
    Authorization: Basic cmF5OmxvdmViZzUyMA==
    Host: 127.0.0.1:19109
    Accept: */*
    Accept-Encoding: deflate, gzip
    Content-type: application/json
    Content-Length: 45
    
    < HTTP/1.1 200 OK
    < Connection: close
    < Content-Type: application/json
    <
    * Closing connection 0
    JSON protocol response:
    {
       "error": null,
       "result": {
          "data": "0000000020da98309c072ea3a149078ca2571d36f974e2394c05c7f95064200000000000fda36bb7b9b6de35f88aa53ccda700574794b968dad47648ca2962cc6234f8e2ef140104139b257ddf39ccdbd8c9e7d25fc9cc7035a7914916337f507e7d550e01006d015a8f7fc605001400ef1000000d1a411b7fc8890e0000000005240000b9290000a268b756000000000000000000000000000000000000000000000000000000000000000000000000000000008000000100000000000005a0",
          "target": "0000000000000000000000000000000000000000000000000d1a410000000000"
       },
       "id": 1
    }
    [2016-02-07 15:54:10.388011] new block, target 0000000000000000000000000000000000000000000000000d1a410000000000
    Cgminer cant working,got this message:
    Code:
    [2016-02-07 23:54:45] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:45] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:46] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:46] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:46] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:46] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:58] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:58] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:58] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:58] LONGPOLL from pool 0 requested work restart
    [2016-02-07 23:54:58] LONGPOLL from pool 0 requested work restart
    i dont know where is wrong

    help me please
    i will pay litte btc for your help

    THX
     
  2. saymissme

    saymissme New Member

    Feb 2, 2016
    8
    0
    < HTTP/1.1 200 OK
    < Connection: close
    < Content-Type: application/json
    <
    * Closing connection 0 // here?
    JSON protocol response:
     
  3. sambiohazard

    sambiohazard Sr. Member

    Jan 21, 2016
    844
    372
    @ocminer can you help him? I hope you are feeling generous :)
     
  4. Webonaute

    Webonaute New Member

    Jan 11, 2016
    16
    2
    Male
    Senior Web Developper
    Canada
    how did you setup pushpool. I may help you. I am also trying to build a pool.
     
  5. saymissme

    saymissme New Member

    Feb 2, 2016
    8
    0
  6. Webonaute

    Webonaute New Member

    Jan 11, 2016
    16
    2
    Male
    Senior Web Developper
    Canada
    did you push your change on git? cause I dont see any new commit since some year on tenebrix?
     
  7. Webonaute

    Webonaute New Member

    Jan 11, 2016
    16
    2
    Male
    Senior Web Developper
    Canada
    When I try to start pushpool with tenebrix branch I get :
    [2016-02-08 15:51:7.383688] Listening on host :: port 19200
    [2016-02-08 15:51:7.384929] Listening on host :: port 19201
    [2016-02-08 15:51:7.387669] initialized SHA256

    So sound like blake code is not there.
     
  8. saymissme

    saymissme New Member

    Feb 2, 2016
    8
    0
    hi Webonaute,
    sorry,i am later
    my pushpool is working now
    maybe i will share to you
    but the shares diff not insert to my mysql database
    do you have any idea?
     
  9. Webonaute

    Webonaute New Member

    Jan 11, 2016
    16
    2
    Male
    Senior Web Developper
    Canada
    I definitely need to check your code to answer that. but if I need to guest, maybe some sql error or db connection is wrong?
     
  10. saymissme

    saymissme New Member

    Feb 2, 2016
    8
    0
    in my server.json
    Code:
    "stmt.sharelog":"INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES (?, ?, ?, ?, ?, ?,)"
    no difficulty,cant insert the difficulty to my sql


    my easy target is
    Code:
    "rpc.target.bits" : 32,
    do you know how to fix it?
     
  11. Webonaute

    Webonaute New Member

    Jan 11, 2016
    16
    2
    Male
    Senior Web Developper
    Canada
    the sql look broken.

    INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES (?, ?, ?, ?, ?, ?,)

    There is an extra , in VALUES (?, ?, ?, ?, ?, ?,) it should be VALUES (?, ?, ?, ?, ?, ?)
     
  12. jumparo

    jumparo New Member

    Mar 27, 2016
    23
    0
    Hey guys, did you succeed to build this pool for decred ?
     

Share This Page