Major Problem With Cgminer

Discussion in 'cgminer' started by SG-O, Feb 8, 2016.

  1. 2017/12/15 - Decred v1.1.2 released! → Release Notes  → Downloads
  1. SG-O

    SG-O Member
    Developer

    Jan 13, 2016
    104
    86
    Male
    Software Dev
    Milky Way
    I just updated my previous miner version (0.0.1) to the latest (0.0.4).

    Previously everything worked perfectly and I mined a lot of blocks. But now I can't get It to work anymore.
    When I start it, It see,s to work for a few seconds (the average hash rate goes up) but than stops suddenly.
    I also get the following error message:

    Code:
     [2016-02-09 01:04:52] Error: clEnqueueReadBuffer failed error -5. (clEnqueue
    ReadBuffer)
    [2016-02-09 01:04:52] GPU 0 failure, disabling!
    I have a GTX 780.
     
    jimmy16 likes this.
  2. Jamie Keefer

    Jamie Keefer New Member
    Advocate (Twitter)

    Jan 16, 2016
    69
    12
    Male
    I thought 0.0.3 was latest. But it has bugs too. it does not display the miner stats and only reports after the program ends.
     
  3. SG-O

    SG-O Member
    Developer

    Jan 13, 2016
    104
    86
    Male
    Software Dev
    Milky Way
    Showing miner stats, as far as I know, are only shown on AMD Cards, and that was since V0. And this problem is new, as I was able to mine without any problems before
     
  4. jimmy16

    jimmy16 Jr. Member

    Jan 8, 2016
    143
    33
    Male
    I had this but for me it was over heating of my gpu
     
  5. SG-O

    SG-O Member
    Developer

    Jan 13, 2016
    104
    86
    Male
    Software Dev
    Milky Way
    That can't be!
    All this happens 2 seconds after launch, and my GPU is only at 35C
     
  6. jimmy16

    jimmy16 Jr. Member

    Jan 8, 2016
    143
    33
    Male
    35 Celsius = 95 Degree Fahrenheit the shut down default setting in cfminer
     
  7. SG-O

    SG-O Member
    Developer

    Jan 13, 2016
    104
    86
    Male
    Software Dev
    Milky Way
    In CGMiner the default thermal shutdown temperature is 75 C! (You can read about it here: https://github.com/decred/cgminer/blob/3.7/GPU-README , Line 142) By the way no program should use that Fahrenheit rubbish, as it is only used in a few parts of the world, which makes it quite insignificant for any science, including computer science.

    Another thing is, that CGMiner cannot monitor my card as this is not supported for my NVidia card.

    This problem has nothing to do with overheating! I just started my PC and the card is almost at room temperature (27 C) and I still have the same problem after a few seconds.
     
  8. Lee Sharp

    Lee Sharp Sr. Member

    Dec 28, 2015
    308
    217
    Male
    Independent Consultant
    Houston, Texas
    No program should make assumptions and choices for you. Especially for something as trivial as displaying temperature... And seeing as how I live in one of those parts of the would using Fahrenheit, that is what I prefer.
     
  9. SG-O

    SG-O Member
    Developer

    Jan 13, 2016
    104
    86
    Male
    Software Dev
    Milky Way
    That was not what I was trying to say. I was talking about the internal Implementation. But this is another subject. My problem is that I can't mine and that temperature can't be the problem.
     
    Lee Sharp likes this.
  10. jolan

    jolan Sr. Member
    Developer

    Dec 7, 2015
    197
    226
    Male
    Decred Team Member
    Which OS?
     
  11. SG-O

    SG-O Member
    Developer

    Jan 13, 2016
    104
    86
    Male
    Software Dev
    Milky Way
    I am using Windows 7 (x64)
     
  12. Jamie Keefer

    Jamie Keefer New Member
    Advocate (Twitter)

    Jan 16, 2016
    69
    12
    Male
    I am able to pool mine at suprnova, but I am not sure solo mining is working. Should I be getting shares like in a pool? I know this image attached is only logging 16 minutes, but I am using as an example of how I dont get any shares to work on.
     

    Attached Files:

    • log.png
      log.png
      File size:
      28 KB
      Views:
      6
  13. jolan

    jolan Sr. Member
    Developer

    Dec 7, 2015
    197
    226
    Male
    Decred Team Member
    Can you see if running with --no-adl helps at all?
     
    MTraveller and SG-O like this.
  14. SG-O

    SG-O Member
    Developer

    Jan 13, 2016
    104
    86
    Male
    Software Dev
    Milky Way
    This is the normal behavior when solo mining. I get an error message and the mining stops completely.
     
  15. SG-O

    SG-O Member
    Developer

    Jan 13, 2016
    104
    86
    Male
    Software Dev
    Milky Way
    WOW! That did the job! Thanks a lot!
     

Share This Page