[solved] 401 Unauthorized - Linux

Discussion in 'Technical Support' started by Dedale, May 24, 2016.

Tags:
  1. 2017/12/15 - Decred v1.1.2 released! → Release Notes  → Downloads
  1. Dedale

    Dedale New Member

    Jan 13, 2016
    67
    12
    Male
    #1 Dedale, May 24, 2016
    Last edited: May 24, 2016
    Hello ladies and gentlemen.


    I fail to access my own wallet. I cannot even see my balance. I already have an old wallet. Long ago i successfully sent mined decreds to it. I also saw my balance. But now i can't

    So that is what i did:

    ./dcrd --rpcuser [daemon username] --rpcpass [daemon password]

    It showed the usual syncing.

    Then,in another terminal:

    ./dcrwallet -u [wallet username] -P [wallet password] --dcrdusername=[daemon username] --dcrdpassword=[daemon password]

    And then to unlock things, in yet another terminal:

    ./dcrctl -u [daemon username] -P [daemon password] --wallet walletpassphrase [wallet password] 0

    It correctly showed the sentence "[INF] RPCS: The wallet has been unlocked without a time limit." in the second terminal window.

    Then i just tried :

    ./dcrctl --wallet getbalance

    And got that 401 message. I tried to google my question but found answers that were not working.

    EDIT: i fixed it. I don't have my passwords in config files so what i had to do was:
    ./dcrctl -u username -P password --wallet getbalance
     
  2. Dedale

    Dedale New Member

    Jan 13, 2016
    67
    12
    Male
    Is it a way to edit the title to change it to [SOLVED] error 401 etc...

    EDIT: Yes there is ! Edited.
     
    root likes this.

Share This Page