Unable To Connect To Dcrd. Could Not Be Established With

Discussion in 'Questions' started by Hamish MacEwan, Sep 25, 2017.

  1. 2017/12/15 - Decred v1.1.2 released! → Release Notes  → Downloads
  1. Hamish MacEwan

    Hamish MacEwan New Member

    Sep 25, 2017
    New Zealand

    As per the documentation, I haved dcrd running "on another computer (such as an always on server)" And then I want Paymetheus to connect to it remotely.

    I have used rpcuser, and rpcpass from dcrd.conf and rpc.cert from the remote server installation to populate the prompt when I run Paymetheus Standalone:

    Connect to dcrd Capture.JPG

    But the result is:

    Unable to connect to dcrd Capture.JPG

    Suggestions welcome.
  2. Hamish MacEwan

    Hamish MacEwan New Member

    Sep 25, 2017
    New Zealand
    Truly it is written than describing the problem publicly will inspire the answer.

    The connection was refused because I hadn't read the information in dcrd.conf properly:

    ; By default, the
    ; RPC server will only listen on localhost for IPv4 and IPv6.​

    I uncommented the required line:

    ; All interfaces on default port:

    And all's good.

    Thank you.
  3. jrick

    jrick Member

    Jan 4, 2016
    It will probably be easier to debug this with dcrctl on the client machine instead of paymetheus.

    First thing to check is that the server is listening on that interface. You should see some dcrd messages being logged for each failed connection. If not, then add --rpclisten= to your config. After this you should start seeing at the very least error messages for failed connections.

    If this setup still does not work the issue is probably that the RPC server cert does not include that interface in the SANs. There is a tool in the dcrd repo named gencerts that can be used to manually create rpc certificates with additional hostnames or IPs included. It's not in the binary release though, so you would have to install it from source.
    Hamish MacEwan likes this.
  4. Hamish MacEwan

    Hamish MacEwan New Member

    Sep 25, 2017
    New Zealand
    Thank you jrick for the supplementary information.

    "Subject Alternative Name (SAN) is an extension to X.509 that allows various values to be associated with a security certificate using a subjectAltName field. These values are called "Subject Alternative Names" (SANs)."​

    And you were precisely correct, dcrd wasn't listening. Once I fixed that, it did, and worked.

Share This Page